User Tools

Site Tools


devel:compiling_and_running_2.0

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Last revision Both sides next revision
devel:compiling_and_running_2.0 [2019-11-17 18:32]
skyjake [Compiling and running Doomsday 2.0 and 2.1 with CMake]
devel:compiling_and_running_2.0 [2021-09-01 08:36]
skyjake
Line 1: Line 1:
-====== Compiling and running Doomsday 2.0–2.with CMake ======+====== Compiling and running Doomsday 2.0–2.with CMake ======
  
 Doomsday 2 is built with [[https://​cmake.org|CMake]] 3.1 (or later). Doomsday 2 is built with [[https://​cmake.org|CMake]] 3.1 (or later).
Line 34: Line 34:
  
   * Normally you will want to set the ''​CMAKE_BUILD_TYPE''​ to "​Release"​. Note that with gcc/clang, omitting this variable will result in an unoptimized build.   * Normally you will want to set the ''​CMAKE_BUILD_TYPE''​ to "​Release"​. Note that with gcc/clang, omitting this variable will result in an unoptimized build.
-  * Set the ''​PREFIX''​ variable to define the installation root path.+  * Set the ''​DE_PREFIX''​ variable to define the installation root path.
   * Set the ''​QMAKE''​ variable to the path of the qmake tool to use (unless autodetected). This determines which version of Qt will be used in the build.   * Set the ''​QMAKE''​ variable to the path of the qmake tool to use (unless autodetected). This determines which version of Qt will be used in the build.
   * ''​DENG_ENABLE_*''​ are used for enabling and disabling Doomsday features.   * ''​DENG_ENABLE_*''​ are used for enabling and disabling Doomsday features.
devel/compiling_and_running_2.0.txt · Last modified: 2021-09-01 08:37 by skyjake